Problem with Pro Forms / Create post (PODS)

Hello
I have a Custom post type made with PODS. Your name 05 Todas las inscripciones


.

I have used Pro Forms to use a form as a method to record these enrollments in a CPT.

But it does not work. I have checked that the assignment of the fields and ids is correct. But there is something wrong and I don’t know what it is. The fact is that the CPT is created… But without content of any kind.

I would appreciate it if you could tell me what I did wrong.

Hey :slight_smile: The field name is wrong. You’ve inserted Dynamic Data here. This outputs the value of the field.
But you need the exact name of the field there.

Example: {animal} will output “Tiger”. The correct name, which is expected, is “animal”.

Hope that helps.

1 Like

Thanks!
In all cases I have eliminated the legends provided by PODS in the field names. For example: {pods_05_inscripciones_nombre} Do I only have to put {nombre}.
But it still doesn’t work. In the image a screenshot of the CPT that has been created without content

No, {nombre} can’t work because this will output the value, for example “John”. And “John” is not the expected meta name. So, in this example, the correct value would be just nombre, not {nombre}. I can’t say if thats the correct name. I never used Pods, but you should be able to see the correct name in the field settings.

Oh, thank you. How clumsy I am. I thought that by being able to choose the CPTs and, within them, the custom fields (in the same way I do in Bricks) that’s how it would work.
Now I have the problem of the post title, which I would like to be the content of the name field + the content of the last name field… But it doesn’t work in all the ways I have tried.
A clue on this would be very welcome, thanks.