Animations disappear in the timeline

Hi @Daniele,

I experience timelines disappearing, is this a small bug or my mistake?

Happens on this page:

Thank you for taking a quick look!


Hey Heiko! :slight_smile: The only reason for that would be that Bricksforge can’t find your selectors in the current page. After taking a short look, I can’t find a selector #brxe-menu-logo in the page. Could you re-check that? :slight_smile:

Hey @Daniele - thanks so much for looking into this so quickly. Then it was caused by a common Bricks problem: classes and id’s go missing when 2 people work on the site. So: Now I know at least when BF shows this behaviour.

Thank you again, :pray:

1 Like

I’m having this same problem. I have two timelines, one set to min-width: 768, the other set to max-width: 767. Both are using the same selector which is the ID of of the container inside the main section. The animations for both timelines were done and working perfectly. I saved and checked it out on the front end. Everything worked fine. Then I decided to adjust the timing of one of the mobile animations just a little. So I went in the timeline and dragged it one or two clicks to the right and when I let go the timeline dissappeared saying the selector couldn’t be found. But it’s using the same selector as the desktop timeline and that one still works. I double checked every selector.

This is also the second time it happened. The first time was when I only had the desktop timeline and I duplicated it to make the mobile one. Right away it said the selctor was missing despite them both being the same. So I deleted it and built the second timeline from scratch and that worked.

are you using loading conditions for your timeline? There is a bug which causes behavior like that and will be fixed in the new version I deploy today.

I just realized that the timelines are only visible if you’re viewing a breakpoint that they’re active for. I wasn’t expecting that. All good, no problem.

Ah yes, that’s the expected behavior. What do you think? Makes this sense? Or should we change that to allow editing of the timeline also outside the setting rules?

Update: With the new version, you should be able to edit your timeline even if the matchmedia is not matching (backend only of course).

It was confusing because it specifically said that the selector didn’t exist on the page, which I knew it did. So I had no clue what to do to fix it. If it said I had the wrong break point selected it would have made sense.

Basically I had an animation moving horizontal on desktop that needed to be vertical on mobile, so I was trying to duplicate the timeline and just change that one thing, but the timeline wouldn’t appear because I had the wrong breakpoint selected. So it sent me on a road trying to trouble shoot a problem with the selector that wasn’t actually the problem.

It would be nice to have the timelines always visible. I was switching back and forth trying to copy and paste things from one to the other.