Bricks 1.9.1 update breaks if Bricksforge enabled

Hi, I’m having a problem with a Bricks site ( V1.9 ) which works perfectly until I upgrade Bricks to V1.9.1.

After the upgrade a number of Templates break and give errors reporting such as “element container does not exist”.
I reported this to BricksExtras - as the header template only uses BricksExtras elements and was the most obvious issue. But they say it’s not them.
Reported to Bricks and they said that deactivating Bricksforge removes all errors.

Indeed deactivate Bricksforge and I can update ok and the site works. If I then activate Bricksforge the site immediately breaks again.

If you look at the Bricks forum - NO BUG: Bricksforge causes issues in 1.9.1 - Bugs - Bricks Community Forum you’ll see some screenshots showing the errors.

I now have a staging site and can give you access to test if you like.

FYI: In BF I only have a few parts enabled.
Elements: Pro Forms and Options
Extensions: Form Submissions, Dynamic Data Tags, Email Designer.
The only thing I’ve used so far on this site is Pro Forms.


1 Like

I’ve done some more investigating.

I tried turning off the Bricksforge settings one at a time.
This included the Global classes.
With everything off and just the Proforms element enabled, the site started working ok. ( Its now at Bricks )

I slowly turned each setting back on and the site still works.

Only thing I can think of is that maybe there is some issue in the Global classes, as i see things like root which I believe Bricks has changed, and I see classes for .container which is one of the errors messages produced.

Rolled back to Bricks 1.9 ( wpVivid backup/restore. ) Site works fine.
Upgraded Bricks to - site now broken.

In BricksForge I disabled the Global classes - was Activated but globally disabled. No Improvement
Under BF Customizing I clicked on the Disable All - even though nothing was showing as enabled.
This fixed the site which is now working ok.

So not at all clear why but clearly something to do with the Customizing section of Bricksforge causing the problem.

But just to complicate things. I tried to recreate the site on other test sites … and it does not always have the upgrade issue even if BricksForge has everything enabled in Customization. So there is clearly something else involved, but no idea what.
I’ll keep testing.

Thank you for this report! There was even already a Facebook post where I ask for users who have the same problem. Unfortunately I can not reproduce it, so I need access data to a page that has this problem. Unfortunately, no one has replied. For most users, there doesn’t seem to have been any problems with the update. Still, a few are reporting it, so it must be an isolated problem that we need to find the cause of.

What is certain is that it is related to the “Customizer”. For a reason I cannot yet explain, during the update to the new Bricks version, some users had all toggles reset in the Bricksforge ‘Customizer’ tab. These toggles determine which elements should exist for related user roles. If you re-enable the toggles, the problem is resolved. So, it’s simply a matter of resetting certain settings.

Do you have a site where this still happens? If yes, could you provide access?

Hi, Many thanks.

I don’t use Facebook, so I’d not see any requests there.

Yes I have a site that has the problem. Bricks support has been looking at it so I’ll restore the Bricks V1.9 version and send you the details.


1 Like

That would be really helpful. Thanks!


Thanks! I see that in the Customizer tab, already in version 1.9 all toggles are disabled for the Administrator user role. Question: did you disabled it manually at some point? Or did you never touch this area?

I had not touched those before.
My initial use of BricksForge was just for the ProForms. Although more use will come later in my build.

In tests it doesn’t seem to matter if I leave the Customizer with all disabled or all enabled, as long as I make that initial toggle switch everything then seems to work. Weird eh?

Fixed. Thanks so much, @alanj. I could reproduce and fix the issue. The new version is coming this week :slight_smile:

1 Like

Daniele, Thank you very much. Looking forward to it!