Colour not rending on 3D Model

Hi Daniele,

I’m very new to the 3D Modelling feature so this may be something I’m doing wrong my end and not necessarily a bug.

I have followed the documentation and uploaded the zip file containing the .gltf which is displaying the 3D model correctly in the builder, but the model is being generated without colour and I’m not sure why.

link to model can be found at beetest – Luke Juan

If you need login details to troubleshoot then let me know.

Thank you!

Is your model rendering here correctly? https://gltf-viewer.donmccurdy.com/

Hey,

No, it’s still rendering without colour. (screenshot attached).

Then it’s the model which seems to have an issue :slight_smile:

I have tried some other 3D models and uploading them into the link you provided to test them and none are rendering in colour? The zip files containing the gITFs are from SketchFab.

Would you have any idea why this is happening?

Have u tried using .glb instead of .gltf (if the format is provided). Generally to show textures on a 3D model using glb or gltf, those textures need to be baked down into image textures. This model is using at least one material which can’t be interpreted.

image

My first try would be to open the model in Blender and see if it shows correctly there. If it does, bake down any textures that aren’t baked yet and re-export. Not sure how much experience you have in Blender so if you can provide the file, I can have a look one of these days :slight_smile: