Datepicker does not show up on frontend

I use datepicker and it does not appear on frontend (in bricks it appears)

Eten in Biezoender – Biezoender (the form is on popup called by big red button)

One more issue with date-picker… My website is in Dutch (it is set in the wordpress settings), but the calendar is in English. How to fix it?

Not sure about the not showing, since you seem to already have swapped it for a native bricks form.

As for localization…
Scroll all the way down here → Form Element – Bricks Academy till u reach " Localize the date picker strings". Then just paste the code as instructed in the article, put in your form id and switch the XX for your locale which I guess is nl. You can find all available locales here →

I understand the problem. The FlatPickr library is currently loaded only when it detects that there are forms with date field on the page. Since you are using Bricksforge popups and they are reloading the content via Ajax, Flatpickr is missing here. I’ll see how I can solve the problem. As a workaround, you could use native Bricks popups here. The native ones are not loaded via Ajax and are in the background of the page. So Flatpickr will load properly here.

That’s a pity that I need to chose between a bf popup and a pro-form with date picker. I liked how BF popup smoothly appears and dissapears. I can’t make it with genuine bricks. Well, I have to choose this time. But I hope in future projects I won’t need to choose if I happen to have the same combination )).

I use Bricks Popup now. Datepicker is shown now. But it scrolls with the page. Here is the video:

The Bricks native form has the same behavior on popups. Just prevent the body to scroll while the popup is open deactiating the "Scroll (body) control:


thank you for the tip. though it does not work with me. it is deactivated, but the page still scrolls. I guess I should write to bricks support now.

The reason why Scroll Body disabling didn’t work for me and the page still scrolled when popup is visible is the BF Smooth Scroller… One more feature that I have to disable :frowning:

Hope for a solutions someday.

Change to Lenis Scroll Smoother. That’s a GSAP limitation. We can’t do nothing to fix that. GSAP is changing the scroll context. Lenis will work much better here. You can change the provider via the settings icon on „Scroll Smoother“.

Check also the note here: Scroll Smoother – Bricksforge Docs

Nope, it was set to lenis initially. When i got the reply on bricks forum, i tried to switch to gsap. But the page stoped scrolling at all(scroll bar moved, but the page content didn’t ) . So i switched back to lenis. This behaviour is when lenis is set… Now i disabled the smooth scroller and the page does not scroll when popup is visible.

here is the proof )