"Does not use HTTPS" error after Custom Fonts Bulk Upload

Hi Daniele & Bricksforge Community!

So I used the awesome tool to load multiple custom fonts at once and it REALLY improved performance for one site, but not another. I’m getting a bunch of HTTPS errors on this one:

https://pagespeed.web.dev/analysis/https-norcaldermatology-com/9ny8cwccjp?form_factor=mobile

So this leads to 2 questions:

  1. Did I do something wrong when I initially uploaded them? I tried to follow the instructions in the video exactly…
  2. How do I resolve this issue?

AND I have a 3rd question:
3. In the video, @Daniele uploaded ALL the fonts from the font source. Wouldn’t ONLY loading the WOFF2 or TTF files improve performance and save unnecessary resources on the DB? It would work the same, right?

I’m a Bricksforge fanatic. Daniele, that’s for this incredible tool.

Best,
Steve

OK so I don’t know what went wrong initially but I do know how to solve this problem now.

I downloaded Real Simple SSL, click the few buttons to make the whole site https and the site was good to go. I immediately activated and deleted the plugin after.

I’m wrong. It didn’t fix it.

I have no idea what the problem is, so I’ve deleted the custom fonts and gone back to loading Google Fonts externally.

Funny, this worked on other sites. Not here though.

Hey Stephen

I use https://www.quic.cloud/ to deliver my content. Like you, I moved serving the font locally instead of via google.

I personally don’t think that you need really simple SSL if your hosting is doing the job.

It may be worth reaching out to Simon Gajdosik in the inter circle as he’s quite responsive. I think I remember you moved or were going to move to Runcloud.

@Daniele It would be nice if there was some way for the fonts to be served cached by default. If not should users best practices on using locally stored fonts. I had the same problem as @Revere I resolved this with a CDN.

I do also think @Daniele that it’s a shame that this post wasn’t acknowledged.

1 Like

Oh, don’t worry. I know he can’t get to everything.

That’s what this great and growing community forum is for!

That’s why I also try to answer my own questions when I figure out the answer elsewhere.

I try to answer questions when I can - and I really appreciate your helpful answer! Thanks @seaj1one!

It’s Easter weekend, and many countries take 4 days holiday.

1 Like

Hey there! Apologies for the delayed response, we had a four-day holiday here in Germany and, to be honest, I also needed some rest… :smiley:

Regarding the Fonts Upload issue, we simply utilize the native Bricks mechanism to upload fonts. Our feature adds a wrapper to assist you in pre-filling the “Custom Fonts” input fields, and once you click “Save”, Bricks handles the rest.

Unfortunately, I’m not sure what might be causing the problem you’re experiencing. It’s possible that you uploaded all the Google fonts when your site wasn’t SSL protected, resulting in the fonts being stored in the database as an http-version? To resolve this, you would need to update the URL of the fonts in the relevant input fields.

I also noticed that some users are currently encountering issues with the custom font functionality following the latest Bricks update. You can find more information on this issue here:

Perhaps this is the cause of your problem? Please let us know :slight_smile:

2 Likes

I had the custom font issues. I just clicked on update on the fonts and cleared the bricks cache and it all worked.

1 Like