Issue with Files with Query Loop

Hi Daniele,

I’ve come across an issue with the file upload on nested controls. When I use it on a query loop, the files always get added to the first post in the list.

The file gets added to the first post. It also looks like it gets added twice?

Another issue is when you click submit on any form, it causes a duplicate submit. I came across this issue when saving files as it was adding the file twice.

This also happens when there are no files attached?

I created the Pro Form as a template, as I will use it for adding new tasks as well. It is used in another template which has the query loop, and that template is used on a page.

Also, there is an issue with the Rich Text control. If you add a bank line and save, the blank line is removed when you refresh?

Site url

Your login details are still active.


Came across another issue with the Rich Text control. If your data has a link in it, it messes up how it displays on the frontend.

I hte below image, the form content ends after the link but when it is displayed, the full contetns duplicate and additional html is created due to it.

I tried getting the information from a function and use htmlentities() to convert the thml tags but this means that the tags are then shown, as they are not being read by the control.


Don’t think the image showed up correctly. Here it is again.

Hey :raising_hand_man:t2:

Regarding the first issue: seems you’re using some Ajax based stuff like WPGridBuilder? If so, please update to 2.0.10. it should solve the issue :blush:

Also, when updating the post meta, what’s your inserted post ID? When using a query loop, you need to include the post id with dynamic data here to update the correct indexed item instead of the first one.

Regarding the Rich text: strange. How it behaves after updating to the last version? Still the same?

Hi Daniele,

Thanks for for that.

The update does fix the issue with the file being added twice, thanks. But it still adds it to the first instance of the Pro From element on the page, which it the New Task form, which is shown as a modal.

The issue isn’t when saving the form but when the file is added, no matter what form I add it to it gets added to the first instance?

The issue with the RT is still the same unfortunately.

Also, my field labels have disappeared after updating, they don’t show up in the bricks editor either?

Regarding the labels: Make sure that in the Pro Forms parent you have “Show Labels” activated, because there is a connection since this update to make things easier :slight_smile:

Regarding the image: Ah okay. So the image will be saved correctly, but the preview image appears in the wrong location?

Show labels was already active, I toggled it as well just in case but they still don’t show up.
I might have a slightly different setup, than normal. I have created a template that holds the form fields in a container and then I have another template with the ProForm, which I use for creating tasks, and another template with the Pro Form, which I use for updating tasks. The form field template is used in both. This means I can then set the Pro Form separately, while reusing the fields. This worked well for me, except now the labels aren’t showing.

As a test I added a new field to the ProFrom and the label comes up for that, so maybe if the form isn’t found, and it can’t set the label visibility, then they aren’t shown. Maybe you could change the default to show?

The file gets added to the first form. If I save the form it should be on nothing is added, as the form object doesn’t contain the files. If I save the forrn that they do show on, then they are saved with that form. I had to create my own save function for files, as it wasn’t working correctly for me with MB file field. The files needed to be saved in individual rows but Pro Forms was saving them as an array in a single row.

This issue occurs because every file field of your form has the same id/name. This can be solved to include dynamic data like the {post-id} as prefix/suffix, for example: fld_files-{post_id}

Hi Daniele,
I realised there was another issue, related to having the form fields in a separate template. The asterisk isn’t showing on the required fields. If I add a field directly to the Pro Form then they show up.