Pro Forms Entries Not Submitting

So you can check it out here:

Under the images on the home page, there’s a “Reserve Now” button, and if you click on that the Popup will show with the form in it. Feel free to try to make a reservation. You probably won’t be able to.

No matter what I do, I can’t get the “Confirm” button to make the form submit. What sorts of things can prevent it from working? Any ideas on what I’m missing, Community?

As an aside, after you click on that “Reserve Now” button, the text drops down to the bottom of the button. What’s that about? Anyone know how to solve that one?

Thanks Bricksforge Community!

Okay, so I got to the backend of Bricks and realized that those submissions are being stored in the “Submissions” table that is created. But the redirect isn’t working and there’s no success message. What prevents this folks?

Thanks again.

If checking the console for errors, I see that the server answers with: Maximum submissions reached. Did you add a limit for submissions? If yes, you can add Submit Button Conditions to inform the user that submissions are not possible, for example by hiding the submit button, show an alternative text or simple set it as “Disabled”. Let me know if that helps :slight_smile:

1 Like

Hi @Daniele ,

First off, thanks for the rapid assistance!

I added that limit when I thought it wasn’t recording the entries, but now that I know it’s recording the entries, I removed that limit.

Same behavior.

The only error that I saw in the console upon submission was the following:

Cookie “mailpoet_page_view” does not have a proper “SameSite” attribute value. Soon, cookies without the “SameSite” attribute or with an invalid value will be treated as “Lax”. This means that the cookie will no longer be sent in third-party contexts. If your application depends on this cookie being available in such contexts, please add the “SameSite=None“ attribute to it. To know more about the “SameSite“ attribute, read Set-Cookie - HTTP | MDN

Just to check it out, I deactivated MailPoet, and still nothing happens with click on the front end.

I have 3 “Actions” set up - “Create Submission” (working), Redirect (not working) and Email (not working). Also, I have the “Success Message” in there and the redirect is supposed to occur after 300ms, but the Success Message isn’t displaying either. Nothing happens when you click - which has already led to me testing myself into almost 2 dozen submissions.

Q2: How do we delete submissions? Do we have to go into the DB to do that right now?

Thanks in advance again ~

Hey! :slight_smile:

Could you send me access for the first one? Seems that something wrong happens with the submissions action, which stops the process to continue. Would be really helpful to debug this :slight_smile:

Regarding Q2: Just posted this on Facebook:

After this fix, you can delete submissions using the checkbox(es). If you need it before next week, I can add this fix to your site :slight_smile:

1 Like

No worries on the submission deletions. I can wait for the update.

Admin info sent. Thanks again for the prompt, outstanding support!

While you’re in there, if you happen to see a setting that I got wrong regarding scrolling on mobile, please let me know about it @Daniele .

I’m noticing that when you scroll on mobile, it only scrolls the site in the background, not the modal/popup. Maybe I got some setting wrong on the popup? If I did and you notice it, please let me know and I’ll go in and change that too.


Hey! :slight_smile:

Regarding the form issue, while debugging, I noticed that even the native Bricks Form is not submitting within your popup. But if opening the template in a normal page (Under Construction - Sample Free Bar Website), both forms are submitting as expected.

Then I found the cause. You’ve setup an interaction for your popup template which causes conflicts with the submit button. Seems that you are listening for a click event for the submit button. Of course this will not work :slight_smile:

When removing this interaction, both forms are submitting also within the popup.

Regarding the second issue: that’s the expected behavior of Smooth Scrolling Providers. Currently you are using GSAP for that. With the GSAP Scroll Smoother, it’s more complicated to react to such things. Will be easier to just change the provider to “Lenis”. With Lenis, you can just add the data attribute data-lenis-prevent to allow nested scrolling for containers of your choise:

For your setup, I’ve changed the provider to Lenis and add the data attribute to your popups to allow nested scrolling :slight_smile:

That’s it. If you need further help, please ask me :slight_smile:

1 Like

Oops!!! Thanks so much for digging up my mistake.

I’ve been thinking about announcing why I love Bricksforge in the Inner Circle, but now I owe it to you. I’ll get something up next week for sure.

That’s support that goes above and beyond @Daniele. Thank you!

1 Like

Thanks very much :slight_smile: I’m happy if I can help!

Have a nice weekend! :raising_hand_man:t2:

1 Like