Submissions problem on WPML

I created Availability form and everything worked till I didn’t install WPML, activated 2 more languages and duplicated availability form on 2 new languages.
Tried to change Form title, change form ID on each language, nothing helped… now even primary EN language submission doesn’t show new submissions anymore…
Under Submissions I can see only form in primary EN language
Any idea?
Thank you!

Can you send me access? Never used WPML…so don’t know what could cause this :slight_smile:

Found the issue. As you can see in the screenshots, the form elements are just duplicated. Therefore the data-script-id and data-element-id is always the same:

To fix this, just duplicate the form and use the duplicated one. Bricks will generate new IDs when duplicating an element. Hope that helps :slight_smile:

Thanks a lot! I will test it…

1 Like

Unfortunately it still doesn’t work. I changed/duplicated all forms (on all languages) but still only can see old data ID in Submissions,… don’t get it…

Screenshot 2023-07-13 at 18.49.57

It definitely doesn’t work… I disabled Form Submission, deleted all Submissions data, disable extension, removed from form action then re-enable everyhting again…
After that I filled one form and submited it… nothing happened inside Submissions - can’t get form name inside and see details/fields from submitted form…

Found the issue! Its related to hCaptcha. Will deploy a hotfix later!

@hech Please try it with the update :slight_smile:

Daniele, it works now, thanks!

1 Like

Hi @Daniele i have same problem, WPML / bricks form element / bricksforge 1.0.1 (all plugins are actual).

Tried duplicate form to generate new ID. Change element ID. Both not worked.
Using google recaptcha v3. (same without recaptcha)

Do you have any idea?


Can you re-check, if the Form ID is different as well checking the DOM? :slight_smile:

ID is different, another language is also hide on frontend. What do you mean checking the DOM? Thanks.

Feel free to send me access via DM. Will take a look :slight_smile:

I can confirm that there is no bug. Form Submissions are not working with the basic Bricks Form. You need to use Pro Forms to save submissions into the database. Will keep the tag “No Bug” here :slight_smile: