Timeline self delete/then unusable if typing a point or coma in the "selector to animate" field


Timeline self delete and then is unusable (not showing any animation) if typing a point or coma in the “selector to animate” field. I tried to add multiple id in this field to make a stagger with multiple objects but when tried to type a coma my timeline element deleted itself. Trying to type anything in the other timelines fields value deleted the other timeline elements (with no way back). Then when creating a new timeline element the visualisation timeline was not working anymore (saying there was no animation). I add to delete the whole timeline to make it work again.

If you want to reproduce this bug, you only need to type a “.” (point without quotes) in the “selector to animate” of an animation inside a timeline. If this char is not the first one to be typed the bug appears.

Thanks for your help.

I don’t know if it’s normal or not I just bought the plugin yesterday but in my opinion it’s unusable at this state. Timelines elements are deleting when typing in the “selector to animate” field, not only when trying to have a . or a , I don’t really understood when it’s happening but seems that using the “backwards” key causes troubles too. When one of this bug occured the timeline isn’t rendering at all, only way to make it works again is to delete the whole timeline and start from 0…

Apart from that, the scrolltrigger is only triggering a javascript error and not working :confused:

Hey! There is a bug in the current version causing this. I’m already working on the fix and will deploy a new version tomorrow / friday. Sorry for this trouble! :frowning:

Glad to know it’s a known bug, it was driving me crazy :joy:

1 Like

Hehe…sorryyyyy :see_no_evil:

1 Like